BGPコミュニティとは何ですか?

2026年8月13日公開

← 用語集のすべての項目 Bへジャンプ

BGPコミュニティとは、1つ以上のルートに共通の属性を付与するパス属性であり、これにより、ルーティングポリシーはプレフィックスを1つずつ処理するのではなく、そのグループ全体を一括して照合、フィルタリング、または変更することができます。「no-export」や「no-advertise」などのよく知られた値は、タグ付けされたルートがどこまで伝播することを許可するかを制御します。

主なポイント

  • BGPコミュニティは、ポリシーマッチングのために、共通の属性に基づいてルートをグループ化します。
  • 標準的なコミュニティでは、AS:value 形式または単純な10進数形式が使用されます。
  • no-export や no-advertise といったよく知られたコミュニティでは、伝播が制御されています。
  • 拡張された大規模なコミュニティでは、よりきめ細かなタグ付けを行うために、より多くのビットが割り当てられています。
  • Versa VOSデバイスは、eBGPおよび再配布ポリシーにおいてコミュニティの照合と設定を行います。

このページの内容: その重要性仕組み種類BGPコミュニティとVersaよくある質問

BGPコミュニティはなぜ重要なのでしょうか?

コミュニティがなければ、ルーティングポリシーでは、個別に扱いたいすべてのプレフィックスを列挙する必要があります。しかし、ネットワークが変化するにつれて、このリストはすぐに古くなってしまいます。コミュニティを利用すれば、ネットワークへの進入点でルートを一度タグ付けし、そのタグに基づいて、すべてのピアリングルーター、再配布ポイント、ルートリフレクターなど、ネットワーク内のあらゆる場所でポリシーを定義できます。そのコミュニティに一致するすべてのダウンストリームポリシーは、特定のプレフィックスを指定する必要なく、そのルートを同じ方法で扱います。

これこそが、大規模なBGPトラフィックエンジニアリングにおいてコミュニティが中心的な役割を果たす理由です。企業は、ルートを「内部専用」「特定リージョン限定」、あるいは「特定のVRF向け」としてマークし、プロバイダーはピアに対してブラックホーリングや選択的アドバタイズメントを通知します。コミュニティは標準的なBGP属性であるため、ベンダー間をそのままの形で伝播します。これは、独立して管理されるネットワーク間でルートの挙動を調整するために用いられる共通言語なのです。

BGPコミュニティとは何ですか?

BGPコミュニティは、オプションの推移的パス属性です。RFC 1997では、これを32ビットの値として定義しており、通常はコロンで区切られた2つの16ビットの半分の値として記述されます(例:AS:value)。 65000:100) – BGP更新メッセージ内のルートに付加される。この属性はリストであるため、1つのルートに複数のコミュニティ値を同時に含めることができる。

元の標準コミュニティ以外にも、2つの拡張フォーマットが存在します。RFC 4360で定義された拡張コミュニティは、64ビットをタイプフィールドと値フィールドに分割して使用し、MPLS VPNのルートターゲットなどのより詳細な情報をエンコードします。RFC 8092で定義された大規模コミュニティは、3つの4バイトフィールドを使用して、4バイトのAS番号を適切にサポートします。 標準規格自体によって、いくつかのよく知られたコミュニティが予約されています。「no-export」はルートをローカルAS内に留め、「no-advertise」はルートのBGPピアへの到達を完全に阻止します。

BGPコミュニティの種類

BGPコミュニティは、3つのフォーマットファミリーと、予約済みの既知の値のセットに分類されます。

標準的なコミュニティ 元の32ビット属性であり、2バイトのAS番号と2バイトの値として記述されています(65000:100) または単一の小数 – ベンダー間で最も広くサポートされている形式です。

拡張コミュニティは幅を64ビットに倍増させ、タイプ/サブタイプフィールドと値フィールドに分割されます。これらは構造化データ(最も一般的なものはMPLSレイヤー3 VPNのルートターゲット)を格納し、マッチングと設定で異なるフォーマットを使用します。

大規模なコミュニティでは、1つのフィールドを2つの2バイトの半分のフィールドに分割する代わりに、3つの独立した4バイトのフィールドを使用しているため、4バイトのAS番号を、その値からビットを借用することなく表現することができます。

よく知られているコミュニティは、ベンダーに関係なく標準化された意味を持つ予約済み値です。「no-export」、「no-advertise」、「no-export-subconfed」は、他のポリシーとは独立して、ルートがどの程度伝播するかを制御します。

BGPコミュニティとVersa

Versa VOSデバイスは、eBGPルーティングポリシー内でBGPコミュニティを直接照合・設定します。あなたが eBGPの設定, 各送信または受信ルールでは、2バイトまたは4バイトの10進数を使用してコミュニティフィールドと照合することができ、 2-byte:2-byte プレフィックス条件に加えて、ペアまたは正規表現を指定できます。「許可」ルールでは、同じポリシーでコミュニティ値を設定し、ASパスにローカルAS番号を先頭に付加することができます。

Concertoでは、再配布ポリシーにより、このモデルがBGP、OSPF、静的ルート、SD-WANといったプロトコル間を移動するルートにも拡張されます。条件式はコミュニティまたは拡張コミュニティの文字列と一致させることができ、そのアクションによって、再配布されたルートにコミュニティ、拡張コミュニティ、または既知のコミュニティを設定できます。これにより、OSPFからBGPへルートが移行する際にタグ付けが行われ、下流のポリシーではプレフィックスを再マッチングすることなく、そのタグに基づいて処理を行うことが可能になります。

よくある質問

標準のBGPコミュニティと拡張BGPコミュニティの違いは何ですか?

標準コミュニティは 32 ビットの値であり、通常は「AS:値」という形式で記述されます。拡張コミュニティはこれを 64 ビットに倍増させ、タイプフィールドと値フィールドに分割することで、MPLS VPN のルートターゲットなどのデータをエンコードできるようにしています。これら 2 つは、照合および設定において異なる形式を使用します。

「輸出禁止」コミュニティはどのような活動を行っているのでしょうか?

「no-export」は、そのルートを受信したすべてのBGPスピーカーに対し、ローカル自律システムまたはコンフェデレーションの外へそのルートをアドバタイズしないよう指示します。これはBGP標準自体で定義されたよく知られたコミュニティであるため、標準に準拠したルーターであれば、追加の設定なしにこれを順守します。

BGPコミュニティと大規模コミュニティの違いは何ですか?

RFC 8092 で定義されている大規模コミュニティでは、1つの4バイト値を2つに分割する代わりに、3つの独立した4バイトフィールドが使用されます。この余分なスペースにより、4バイトのAS番号を使用しているネットワークでも、標準的なコミュニティで必要となるようなエンコーディング上の回避策を講じることなく、コミュニティを明確に表現することができます。

1つのルートに複数のBGPコミュニティを含めることはできますか?

はい。「community」属性はリストであるため、1つのルートで複数の値を同時に指定できます。たとえば、地域タグと「no-export」フラグを組み合わせて指定することも可能です。これにより、ルーティングポリシーでは、いずれかの値、あるいはそれらの組み合わせに基づいてマッチングを行うことができます。

BGPコミュニティとASパスはどのように異なるのでしょうか?

ASパスは、主にループ防止を目的として、ルートが通過したすべての自律システムを時系列順に記録するものです。コミュニティとは、事業者がポリシーに基づいてルートにタグを付けるために意図的に設定する属性であり、履歴は保持されず、自動的に設定されることもありません。

BGPコミュニティの詳細

さらに詳しく知りたい場合は、私たちが信頼している情報源を以下にご紹介します。

RFC 1997: BGP コミュニティ属性 RFC 4360: BGP 拡張コミュニティ属性
32ビットのコミュニティ属性に関するIETFによる当初の定義、そのよく知られた値、およびBGPスピーカー間でどのように伝播するかについて。 拡張フォーマット規格:64ビットコミュニティ、そのタイプ/サブタイプ構造、およびMPLS VPNにおけるルート・ターゲットとしての利用。

BGPコミュニティについて調べているなら、次はこれらもぜひチェックしてみてください。

静的ルート インターネットプロトコルセキュリティ パス
ネクストホップ、メトリック、およびプリファレンスが定義された手動設定のルート。これは、再配布ポリシーでタグ付けできるもう1つのルートタイプです。 IPトラフィックを安全なトンネル内で暗号化するプロトコルスイート。eBGPピア間では、IPsecで保護された経路を介してルートが交換されることが多い。 2つのSD-WANブランチ間のエンドツーエンドのルート。つまり、BGPによって学習されたルートが最終的に通過するアンダーレイのことです。
この記事は役に立ちましたか?
問題を報告する