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About This Document 

This guide provides a comprehensive, use case based step-by-step configuration for setting up Versa SSE 

Secure Access policies and Protection Rules to use EIP for compliance and access control. 

Endpoint Identity Profile (EIP) is an advanced security feature in Versa’s SASE architecture that enables 

dynamic, context-aware access control based on the user device's posture and identity. EIP collects rich 

telemetry from endpoints—including device type, OS, patch level, running processes, security posture, and 

more—and uses this data to enforce Zero Trust policies in real time. 

EIP ensures that access to sensitive applications and resources is granted only to trusted, compliant, and 

authenticated devices. Whether managed or unmanaged, each endpoint is evaluated against customizable 

policy criteria before access is allowed. 

As part of the Versa Secure Access Service Edge (SASE) framework, EIP enhances identity- and posture-

based access by seamlessly integrating with the Versa Secure Private Access (VSPA) solution. This 

empowers organizations to enforce least-privilege access, reduce their attack surface, and enable secure 

remote work with confidence. 

EIP combines endpoint telemetry, identity management, and security intelligence to deliver continuous, 

adaptive access control across distributed environments, simplifying Zero Trust enforcement for enterprise 

users and devices. 

Document Information  

Title Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

Author Versa Professional Services 

Version V 1.0 

 

Disclaimer 

Information contained in this document regarding Versa Networks (the Company) is considered 

proprietary. 

Before you begin 

Before you proceed with the steps outlined in this document, please ensure you’ve met the following 

prerequisites. 

• The provider administrator must complete your tenant configuration. If you haven’t received this 

information, please contact your Managed Service Provider or Account Manager for assistance. 

• You have the Enterprise Administrator (Tenant Admin) credentials for the Versa SASE portal, also 

called the Concerto User Interface. 

• You have administrative access to the Microsoft Azure Portal, specifically App registrations, 

Enterprise applications, and Intune configuration pages  
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Introduction 

Endpoint Information Profiles (EIPs) protect the enterprise network and resources by ensuring that 

endpoint devices accessing the network maintain and adhere to enterprise security standards. 

Versa EIP Building Blocks 

EIP Objects: Define the match criteria for an EIP profile. The match criteria filter the raw data 

reported by endpoint devices (fetched by the SASE client and matched on SSE gateways). 

EIP Profiles: Groups a collection of EIP objects as match criteria within the Secure Access Rules and 

Security Policy, which are evaluated when a user attempts to connect to SASE portals and gateways, 

or when permitting user traffic through Protection rules. 

EIP Agent: Define the conditions that the SASE client uses to filter information from endpoint 

devices for continuous evaluation. When you configure a SASE portal policy, you associate the agent 

profile with an enforcement action. 

General Configuration Steps for EIP 

Now that we have covered the concepts of EIP Object, Profile, and Agent, let’s move on to the configuration process. 

Configure EIP Objects 

Endpoint Information Profile (EIP) objects in Versa SASE define the criteria for evaluating endpoint 

device posture. These objects enable the system to collect and validate endpoint attributes such as 

antivirus status, firewall settings, and browser presence. 

Each EIP object operates according to strict logic, meaning that all configured conditions must be 

met for the object to register a successful match. As referenced in the Versa documentation, “all 

elements in [a rule] must match for entities to be associated with the... EIP profile. 

There are two types of EIP objects available: 

 

• Predefined Objects: Delivered by Versa and ready to use on EIP Objects, there are already 156 EIP 

objects created under different categories. 

 

EIP Categories – Description Table (Versa SSE) 

 

Category Description 
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Antimalware 
Identifies and categorises endpoint applications that detect, block, or remove malware 

such as viruses, trojans, ransomware, and similar threats. 

AntiPhishing 
Covers endpoint components designed to detect or prevent phishing attempts, 

including URL reputation checks and suspicious-link filtering. 

Disk Backup 
Includes backup agents and utilities responsible for local or cloud-based data backup 

and recovery operations on endpoints. 

Browser 
Classifies browser applications or browser extensions that can influence web access, 

security posture, or data handling. 

Cloud Storage 
Identifies applications used for cloud-based file synchronisation and storage (e.g., 

OneDrive, Dropbox, Google Drive, iCloud). 

Custom 
A flexible category intended for user-defined classifications that do not fall under 

standard EIP categories. 

Data Loss Prevention 

(DLP) 

Categorises endpoint tools that monitor, detect, or block unauthorised handling or 

movement of sensitive data. 

Disk Encryption 
Covers encryption agents that secure data at rest on endpoint storage devices (e.g., 

Bitdefender, Versacrypt). 

Endpoint Security 
Represents comprehensive endpoint security suites that include multiple protection 

capabilities (AV, behavioural analysis, etc.). 

Firewall 
Identifies local host-based firewall components that control inbound and outbound 

network traffic on the endpoint. 

General 
A broad category for benign or standard applications that do not pose significant 

security or data-handling implications. 

Health Agent 
Includes security posture, compliance, or device-health monitoring agents used for 

enterprise policy enforcement. 

Management Status 
Covers remote monitoring and management (RMM) or device-management agents that 

handle configuration, updates, and inventory. 

Messenger 
Classifies messaging and collaboration applications used for real-time chat, 

communication, or file exchange. 

Patch Management 
Identifies agents responsible for OS and application updates, vulnerability remediation, 

and patch deployment. 

Public File Sharing 
Includes applications designed to share files publicly or peer-to-peer, often requiring 

strict control in secure environments. 

Remote Control Covers remote desktop and remote-assistance applications that enable remote access 
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to endpoint systems. 

Virtual Machine 
Identifies hypervisors, virtualization platforms, or VM management tools used to run 

isolated computing environments. 

 

• User-Defined Objects: Customizable by administrators to fit specific endpoint requirements. 

 

To demonstrate how to configure a user-defined EIP object, create an object that verifies whether a 

firewall is both installed and running on an endpoint: 

Navigate to the EIP Object Configuration. Go To: Configure > Security Service Edge > Profile and 

Connectors > Endpoint Information Profile (EIP) > EIP Objects 

 

Step 1 Add EIP Object 

Click on User-defined. Click the + Add button to open the "Add EIP Object" window. 
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Step 2 Fill in the EIP Object Settings 

o Name: Enter a meaningful name (e.g., EIP_Firewall_Check). 

o Category: Select Firewall from the drop-down. 

o Installed: Set to True. 

o Running: Set to True. 

o (Optional) Add other parameters such as: 

▪ Vendor (e.g., Microsoft Corporation) 

▪ Product (e.g., Windows Firewall) 

▪ Version fields: Specify ranges or values for Major, Minor, Patch, or Service if 

needed. 

▪ Realtime, Configured, or Scan Times can also be configured based on the 

endpoint posture you want to evaluate. 

Note: 

For the True, False, and Disabled parameters, you can define how each posture attribute is 

interpreted during compliance checks: 

• True: the condition must be met for the object to match the posture criteria. 

• False: the condition must not be met for the object to match. 

• Disabled: the condition is ignored and not evaluated. 
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These settings determine how the EIP Profile applies its match criteria when validating endpoint 

posture. 

 

 

Drop-down category to firewall option 
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Step 3 Save EIP object 

 

Click Add to create the EIP object. 

 

EIP objects created can now be included in any EIP Profile to enforce policy based on the presence 

and status of endpoint firewalls. Similarly, other categories like Anti-Malware, Browser, or others can 

be configured using the same procedure to strengthen your Zero Trust enforcement. 

 

Configure EIP Profiles. 

An Endpoint Information Profile (EIP) defines the logic for evaluating endpoint posture to enforce 
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access policies. Unlike EIP Agent Profiles, which specify what data is collected from the endpoint, an 

EIP Profile determines how that data is matched against predefined or user-defined posture objects 

to decide whether an endpoint is compliant. 

Each EIP Profile is composed of one or more rules, and each rule includes: 

• A category (e.g., Antimalware, Firewall, Browser, etc.) 

• A list of EIP Objects (posture definitions). 

• Within each rule (Inside same category): 

Matching is based on an OR operation — the rule is satisfied if any one of the selected EIP 

Objects matches the collected posture data. 

• Across rules in the profile (different categories): 

Matching is based on an AND operation — the entire EIP Profile is considered a match only 

if all rules are satisfied. 

Example: 

If a profile contains: 

• Rule 1: AntiMalware (Bitdefender or Defender installed and running) 

• Rule 2: Browser (Chrome or Firefox present) 

• Rule 3: Firewall (Windows Firewall running) 

Then, for the profile to match, the endpoint must satisfy at least one object in each rule. All three 

rules must match — one from each category. 

To demonstrate how to review an EIP profile, the example eip-profile-antiphishing-popular is used. 

This profile gathers details about anti-phishing software. 

So, Navigate to Configure > SASE > Settings > Endpoint Information Profile (EIP) > EIP Profiles 
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To create a user-defined following the next steps: navigate to Configure > SASE > Settings > 

Endpoint Information Profile (EIP) > EIP Profiles, then User defined, and click + Add. 

• Step 1: Navigate to EIP Profile Configuration 

• Go to: 

Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile 

(EIP) > EIP Profiles 

• Click + Add to begin creating a new EIP profile. 
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• Step 2: Add Rules to the EIP Profile 

• Click + Add under the Rules section. 

• Enter a Name and Description for the rule (e.g., Rule1). 

• In the Category dropdown, select a posture category such as: 

o AntiMalware 

o AntiPhishing 

o Browser 

o Cloud Storage 

o Data Loss Prevention 

o …or others available. 

These categories determine the type of endpoint information that will be collected. 
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Step 3: Add User-Defined and Predefined EIP Objects 

• Once a category is selected, you can choose: 

o Predefined EIP Objects: Preconfigured objects provided by Versa (e.g., eip-object-

browser-chrome) 

o User Defined EIP Objects: Custom objects created by the administrator (e.g., 

EIP_Browser) 

• Select the objects relevant to the Profile, then click Add. 

Note: You can add multiple objects under the same profile by repeating this process. 
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+ Add if it requires more than one. 
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Step 4: Review and Save 

• After adding all necessary rules, click “Next” or “Skip to Review”. 

• On the Review & Submit screen, verify the name, description, and categories. 

• Click Save to create the profile. 
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Configure EIP Agent Profiles 

 

An EIP Agent Profile defines the conditions and categories that the SASE client uses to extract 

security and posture information from an endpoint device for continuous evaluation. 

To collect endpoint posture information, you must associate an EIP Agent Profile with a Secure 

Access Rule. 

As a best practice, the EIP Agent Profile and the EIP profile attached to the same Secure Access 

Policy should be the same. 

The process flows as follows: 

1. An EIP Agent Profile is associated with a policy to trigger the collection of endpoint data. 

a. For a Secure Client Access (SCA) policy, you associate the EIP Agent Profile with an SCA rule. 

b. For a SASE Portal policy, when you configure a SASE Portal policy, you associate the agent profile 

with the enforcement action in the policy. 

c.  (Example, versa recommended) to associate with the rule. 

2. Data Collection and Enforcement: 

a. After an endpoint device registers and matches a policy rule with an associated EIP Agent Profile, 

the Versa SASE Client receives the profile. 

b. The client then collects information according to the conditions defined in the EIP Agent Profile. 
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c. This information is reported on the SASE gateway. 

d. The gateway evaluates the information and enforces the security policy. For example, if the profile 

checks for mandatory antivirus software and the client reports it is missing, the gateway can deny 

the connection and display a message to the user. 

Note: If you make changes to an EIP Agent Profile, the Versa SASE client must be reregistered for the 

changes to take effect 

Navigate to Configure > SASE > Settings > Endpoint Information Profile (EIP) > EIP Agent Profiles 

 

To demonstrate how to review an EIP agent profile, the example Antiphishing_category_product is 

used. This profile gathers details about anti-phishing software, including its installation status, 

configuration, and running state. 
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To create User defined following the next steps: navigate to Configure > SASE > Settings > 

Endpoint Information Profile (EIP) > EIP Agent Profiles then User defined and click + Add. 

 

for creating a Versa EIP Agent Profile using the AntiMalware, Browser, and Firewall categories as 

examples. 

Step 2: Add Rule — AntiMalware Category 

1. In the Rules section, click + Add. 

2. From the Category dropdown, select AntiMalware. 

3. Configure the following options: 
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o Installed: True 

o Running: True 

o Realtime: True (optional but recommended) 

o (Other fields like Vendor, Product, or version can be left as Disabled unless required) 

4. Click Add to save the AntiMalware rule. 

 

 

Step 3: Add Rule — Browser Category 

1. Again, click + Add in the Rules section. 

2. From the Category dropdown, select Browser. 

3. Configure the following options: 
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o Installed: True 

o Running: (optional, set to True if you want to detect currently running browsers) 

o Leave other fields as Disabled unless you want to target a specific browser. 

4. Click Add to save the Browser rule. 

 

 

 

Step 4: Add Rule — Firewall Category 

1. Click + Add again. 

2. Select Firewall from the Category dropdown. 

3. Configure the following: 
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o Installed: True 

o Running: True 

o Optionally, configure Vendor/Product/version fields if you want to match a specific fire-

wall. 

4. Click Add to save the Firewall rule. 

 

 

Step 5: Review and Submit the Profile 

1. After adding all three rules (AntiMalware, Browser, Firewall), click Next or Skip to Review. 

2. On the Review and Submit screen: 

o Enter the Profile Name (e.g., EIP_Agent_Test_Company_Portal). 

o (Optional) Add a Description for the profile. 

3. Click Submit to save the profile. 
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Configure EIP on Secure Client Access Rules  

 

In Versa SASE, Secure Access policy rules enable administrators to enforce access controls based 

on the endpoint's security posture. This is achieved by associating two key components within the 

rule: 

1. EIP Profile – A match condition defines how the collected data is evaluated against a set of 

predefined or user-defined posture conditions in the attached profiles. 

2. EIP Agent Profile – Defines what posture information the SASE client should collect from 

the endpoint post registration (e.g., Antimalware status, Firewall state, installed browsers). 

When a Secure Client-based Access rule is triggered, the following flow occurs: 

• On the first connection, the EIP Profile is required to validate compliance before access is 

granted. 

• If the EIP Agent Profile is configured in the Secure Access match rule, it is then pushed to the 

client for continuous posture evaluation during subsequent sessions. 

• The client collects posture data based on the categories defined in the EIP Agent Profile. 

• The collected data is then evaluated at the SSE Gateway using the logic defined in the associ-

ated EIP Profile. 

• The EIP Profile enforces compliance: if the endpoint posture satisfies the conditions, access 
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is granted; if not, access is denied regardless of the rest of the rule’s configuration. 

This approach ensures that only endpoints with compliant posture—such as running antivirus, 

enabled firewall, or verified software—can connect and then access protected resources. 

To configure a secure client access rule, navigate to Configure > Security Service Edge > Secure 

Access > Client-based Access > Rules and click on +Add. 

 

In the rule editor, go to the Endpoint Posture step and locate the Endpoint Information Profile 

(EIP) tile. Click Customize. 

 

Note: In a Secure Access rule, all Match Criteria are evaluated using AND logic. 

Inside the Endpoint Posture tab, multiple EIP Profiles follow OR logic — the endpoint needs to 
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match only one of the selected EIP Profiles for this tab to pass. 

   

In the Endpoint Information Profile (EIP) window: 

• Select User Defined if you want to use one of your custom EIP profiles, or 

• Select Predefined to use a Versa-provided profile. 

Then click Add Existing EIP Profile. 
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After selecting the EIP Profile, the next step in the Secure Access rule is to optionally apply an EIP 

Agent Profile. This step is not mandatory — the EIP Agent Profile is only required if you want the 

SASE client to perform continuous posture evaluation. 

When configured, the EIP Agent Profile defines which posture attributes the SASE client must collect 

after registration, ensuring that ongoing posture updates are sent to the gateway for evaluation. 

In the rule editor, go to the Agent Profile From EIP section under Action. This is where you can 

optionally attach an EIP Agent Profile for continuous posture evaluation. 

 

 

Select the profile type Open the Type dropdown and choose User Defined or Predefined, 

depending on if want to uses predefined Versa the Agent Profile or it was created. 

Choose the EIP Agent Profile From the EIP Agent Profiles dropdown, select the profile you want 

to apply to this Secure Access rule. 



 

28 

 

 

Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

 

 

Continue with the rule configuration Click Next to move to the final review and complete the 

Secure Access rule. 

 

 

 

 

 

 

Configure EIP on Real-Time Protection Rules 

In Versa SSE, Real-Time Protection Rules use EIP Profiles as match conditions to evaluate endpoint 

posture attributes (AV, firewall, disk encryption, etc.) reported by the SASE client. The SSE Gateway 

continuously validates this telemetry against the EIP Profile associated with the Internet Protection 

rule. If the device falls out of compliance, the rule will allow access that does not match, triggering 

the blocking of all new access requests from that endpoint until posture is restored. 

To configure a secure client access rule, navigate to Configure > Security Service Edge > Real-

Time Protection > Internet Protection and click on +Add or from the list of Internet Protection 

rules, select the rule you want to edit, then Edit. 
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In the Match Criteria go to Endpoint posture then click Customize on the Endpoint Information 

Profile (EIP). 

 

 

The Endpoint Information Profile (EIP) window appears. 

o Choose User Defined to select a custom EIP profile (for example, 

EIP_Pro_Crowdstrike), or Predefined to use a Versa default profile. 

o Select the desired profile and click Add. 

o Click Next. 
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Click Save, then Publish to apply the policy. 

 

Key points 

• EIP Posture Update Frequency: 

o By default, the SASE client sends posture data to gateways every 10 minutes. 

o The interval determines how often EIP data is transmitted to the gateway. 

• Full Data Updates: 

EIP posture updates are always sent as complete datasets—not incremental—because gateways 

do not cache previous posture information. 

• Posture Change Detection: 

o If the device's posture remains unchanged, no update is sent. 

o However, the SASE client continues collecting data and detecting changes by com-

paring data hash values. 

o Only upon detecting a change does the client transmit a new posture update to the 

gateway. 

• Real-Time Detection (Selective Categories): 

For specific categories like Anti-Malware, real-time posture monitoring can be enabled. In this 
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mode, the SASE client collects and sends updates to the gateway every 10 minutes when changes 

are detected. 

• Pre-Registration Posture Collection: 

The "Versa Recommended" EIP agent profile is embedded in the SASE client. It begins collecting 

all specified endpoint posture information prior to portal registration, ensuring enforcement 

policies are applied from the moment the client connects. 

 

EIP Scenario-Based Use Cases for Windows 

 The following provides some use cases for configuring EIP validation on Windows Hosts. 

 

Windows Registry Path and Key 

Leveraging Windows registry paths and keys within an EIP Profile allows administrators to validate 

the presence or configuration of specific applications on endpoints. This is useful when enforcing 

access policies based on critical software installations, such as VPN clients or endpoint protection 

tools not in the Versa EIP object list. 

For example, Versa can check a registry path or key to confirm whether an antivirus application (E.g., 

Avast) is installed. If the key is missing or the value does not match the expected configuration, the 

endpoint is flagged as non-compliant, and access to corporate resources may be restricted. 

Step 1: Create an EIP Object with Windows Registry Path 

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Objects  
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Click on “+ Add” to create a new EIP Object.  

 

  

Enter a descriptive name for your EIP object. Example: EIP_Registry_Windows_Avast_Free.  And Select Custom from 

the dropdown. 



 

33 

 

 

Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

 

Go to Windows Registry Validation and enter the full path of the registry key you want to check Example: 

 HKEY_LOCAL_MACHINE\SOFTWARE\Avast Software\Avast 

 

Steps to Find Registry Path 

To find the correct registry path for other applications, open the Windows Registry Editor (regedit) and navigate under 

one of the following common locations: 

• HKEY_LOCAL_MACHINE\SOFTWARE\[Vendor]\[Product] 

• HKEY_CURRENT_USER\SOFTWARE\[Vendor]\[Product] 

You can also search for an application name using Ctrl+F in Registry Editor. As shown below, you would obtain the path 

for Firefox as an example. Once identified, copy the full registry path and enter it exactly in the EIP configuration field. 

 

 

“Exists” Checkbox: If checked, it verifies that the key exists and, if you enter a value in the Value field, it will also validate 
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that the registry key’s data matches that specific value. If the Value field is left empty, the gateway will validate only that 

the registry key exists. If “Exists” is unchecked, the registry key is not evaluated at all, and no validation is 

performed. 

 

  

  

Step 2: Create an EIP Profile Using Windows Registry Keys 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles, then go to EIP Profiles. 
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Click on “+ Add” to start creating a new profile. 

 

  

In the Create EIP Profile window, Click on “+ Add” to define a new rule. 

  

 

  

  

Enter a Name for your rule, for Example, EIP_Profile_Windows_Registry. 

 You would (Optional) Add a description for clarity. 

Click “+ Add” to attach an EIP Object. 
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In Add EIP Object dialog, choose the Category. Example Custom. 

Select an existing EIP Object or create a new one. For example, an object was created to verify if Avast Free Antivirus in 

the previous section. 

  

 

  

Click Next and then Enter a descriptive name for your EIP object. Example: EIP_Profile_Windows_Registry. 

  

Review and Save the Profile creation 
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Note: After creating the EIP Object and configuring the EIP Profile and Agent Profile, you must apply them to the Secure 

Access Client policy to enforce device posture validation and continue evaluation. 

 

Step 3: Navigate to the EIP Agent Section 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Agents 
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Step 4: Create an EIP Agent Profile 

  

Click on Add to create a new Agent profile.  

 

  

Click on “+Add” to create a new rule. Then choose Custom 
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Click on “next” to enter a descriptive Profile Name (e.g., EIP_Agent_Windows_Registry). 
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Step 5: Configure Secure Client Access Rule 

 

Navigate to: 

 Configure > Security Service Edge > Secure Access > Client-based Access > Rules. 

  

Click “+ Add” to create a new Secure Access Client rule or edit an existing rule. 

  

In the Match Criteria configuration, go to the Endpoint Posture section. Under the Endpoint Information Profile (EIP) 

panel, select the desired profile by navigating to the User Defined tab and clicking on Add Existing EIP Profile. Then, 

choose the EIP profile you previously created. Example EIP_Profile_Windows_Registry). 
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In action configuration, under the Agent Profile From EIP section, set the Type to User Defined and select the EIP 

Agent Profile you previously created. Example EIP_Agent_Windows_Registry. The Match Categories panel displays the 

defined validation criteria, such as registry paths or process checks, ensuring that the selected EIP Agent Profile is applied 

during endpoint posture verification. 

  

 

 

Verification  

After a re-registered is not allowed to connect. This is due to the Avast Free antivirus Registry Path is 

not present.  
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Validate EIP profile applied on Secure Client Access Rule. Navigate to Configure > Security Service 

Edge > Secure Access > Client-based Access > Choose appropriate Secure Access Profile click on 

“Name” go to EIP profile 

 

Review on json file “EIPCollectedData.json” In the Path C:\ProgramData\Versa Secure Access\config 
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Go to custom windows registry and check entries. There is Avast free entry however value is empty. 

 

 

Additionally, you can verify posture and access events directly from the SASE Portal. 

Navigate to: View > Dashboard > Secure Access > Users > Events 

 

As you can see, the device is falling into the implicit Deny-All Rule 

 

After Avast Free was installed again. In the Sase Client go to Reregister. 



 

44 

 

 

Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

 

Review on json file “EIPCollectedData.json” In the Path C:\ProgramData\Versa Secure Access\config 

Go to Custom Section. Now Avast free Registry is attached. 

 

Now authentication is allowed.  
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Additionally, you can check the EIP matching rule by going to View > Dashboard > Secure Access > 

Logs > Endpoint Information Profile > Logs and then selecting Endpoint Information Profile. 

 

 

  

 

 

Domain Validation 
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Domain validation in an Endpoint Identity Profile (EIP) verifies whether an endpoint is joined to the 

expected corporate Active Directory (AD) domain. This check ensures that devices are managed in 

accordance with enterprise policies and controls. 

Scenario: 

An organisation requires all Windows laptops accessing internal applications to be joined to acme-

one.com. In the EIP Profile, the administrator configures a domain validation check for that domain. 

When a user connects: 

• If the laptop is joined to acme-one.com, the device is compliant and access is allowed. 

• If it is part of another domain or not domain-joined, the device is non-compliant and access is 

denied. 

Step 1: Create an EIP Object with Windows domain 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Objects 

  

 

  

Click on “+ Add” to create a new EIP Object.  
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Enter a descriptive name for your EIP object. Example: EIP_Windows_Domain.  And Select general from the dropdown. 

  

 

 

Go to Windows Domain and enter the domain name to check Example: acme-one.com 
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Step 2: Create an EIP Profile Using Windows Domain 

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > 

EIP Profiles then go EIP Profiles 
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Click on “+ Add” to start creating a new profile. 

 

 

 

 

 

  

In the Create EIP Profile window, Click on “+ Add” to define a new rule.  



 

50 

 

 

Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

 

  

 Enter a Name for this rule, Example, EIP_Prof_Windows_Domain. 

 You would (Optional) Add a description for clarity. 

Click “+ Add” to attach an EIP Object. 

 

In Add EIP Object dialog, choose the Category. Example general. 

Select an existing EIP Object or create a new one. For example, an object was created to verify if windows domain in the 

previous section. 
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Click Next and then Enter a descriptive name for your EIP object. Example: EIP_Prof_Windows_Domain. 

  

Review and Save the Profile creation 

  

 

  

Note:  After creating the EIP Object and configuring the EIP Profile and Agent Profile, you must apply them to the Secure 

Access Client policy to enforce device posture validation and continue evaluation. 

Step 3: Navigate to the EIP Agent Section 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Agents 
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Step 4: Create an EIP Agent Profile 

 

Important Note: Instead of creating a new agent manually, you can also use a predefined Versa Windows Domain 

agent. In the Predefined tab, search for the domain and select General_category_windomain, which already includes 

the rule Windows Domain: True.  

 

 

Click on Add to create a new Agent profile. 
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Click on “+Add” to create a new rule. Then choose general 

 

  

  

In the general section, locate click Windows Domain by default is set to  Disable change to  true, then Click Add.  
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Click on “next” to enter a descriptive Profile Name (Example., EIP_Agent_Windows_Domain). 
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Step 5: Configure Secure Client Access Rule 

 

Navigate to: 

 Configure > Security Service Edge > Secure Access > Client-based Access > Rules. 

  

Click “+ Add” to create a new Secure Access Client rule or edit an existing rule. 

  

In the Match Criteria configuration, go to the Endpoint Posture section. Under the Endpoint Information Profile (EIP) 

panel, select the desired profile by navigating to the User Defined tab and clicking on Add Existing EIP Profile. Then, 

choose the EIP profile you previously created. Example EIP_Prof_Windows_Domain). 
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In action configuration, under the Agent Profile From EIP section, set the Type to User Defined and select the EIP 

Agent Profile you previously created. Example EIP_Agent_Windows_Domain. The Match Categories panel will display 

the defined validation criteria, such as registry paths or process checks, ensuring that the selected EIP Agent Profile is 

applied for endpoint posture verification. 
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Host ID or System UUID 

Host ID validation in an Endpoint Identity Profile (EIP) uniquely identifies endpoints using their 

hardware-based System UUID. Unlike MAC addresses, the UUID is tied to the motherboard and 

remains consistent throughout the device’s lifecycle. 

Scenario: 

An organisation requires all corporate laptops accessing internal applications to be validated by their 

UUIDs. The administrator configures Host ID validation in the EIP Profile with the authorized UUID 

list. When a user connects: 

• If the UUID matches, the device is compliant and access is allowed. 

• If not, the device is non-compliant and access is denied. 

To retrieve the UUID in Windows PowerShell: 

Get-CimInstance -ClassName Win32_ComputerSystemProduct | Select-Object UUID 

 

Step 1: Create an EIP Object with a Windows domain 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Objects 
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Click on “+ Add” to create a new EIP Object.  

  

 

  

Enter a descriptive name for your EIP object. Example: EIP_Host_ID.  And Select general from the dropdown. 

  

 

Go to Host ID and Enter the System UUDI to check Example: 

 08C60E4C-23BE-00FE-A85C-EE77570DFFFF 
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Step 2: Create an EIP Profile Using Host ID 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Profiles 

  

 

  

Click on “+ Add” to start creating a new profile. 
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In the Create EIP Profile window, Click on “+ Add” to define a new rule. 

  

 

  

  

Create a General Rule for Windows Domain 

Enter a Name for your rule, Example, EIP_Prof_Host_ID. 

 You would (Optional) Add a description for clarity. 

Click “+ Add” to attach an EIP Object. 
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In Add EIP Object dialog, choose the Category. Example general. 

Select an existing EIP Object or create a new one. For example, an object was created to verify if windows host ID in the 

previous section. 

  

 

  

Click Next and then Enter a descriptive name for your EIP object. Example: EIP_Prof_Host_ID. 

  

Review and Save the Profile creation 
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Note: After creating the EIP Object and configuring the EIP Profile and Agent Profile, you must apply them to the Secure 

Access Client policy to enforce device posture validation and continue evaluation. 

Step 3: Navigate to the EIP Agent Section 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Agents 

 

  

  

 

  

Step 4: Create an EIP Agent Profile 

 Important Note: Instead of creating a new agent manually, you can also use a predefined Versa Host Id agent. In the 
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Predefined tab, search for domain and select General_category_hostid, which already includes the rule Windows Domain: 

True.  

  

 

 

 

Click on Add to create a new Agent profile. 

 

  

Click on “+Add” to create a new rule. Then choose general 
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In the general section, locate click Host ID by default is set to Disable change to  true, then Click Add.  

  

 

  

Click on “next” to enter a descriptive Profile Name (Example., EIP_Agent_Host_ID). 
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Step 5: Configure Secure Client Access Rule 

 

Navigate to: Configure > Security Service Edge > Secure Access > Client-based Access > Rules. 

  

Click “+ Add” to create a new Secure Access Client rule or edit an existing rule. 

  

In the Match Criteria configuration, go to the Endpoint Posture section. Under the Endpoint Information Profile (EIP) 

panel, select the desired profile by navigating to the User Defined tab and clicking on Add Existing EIP Profile. Then, 
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choose the EIP profile you previously created. Example EIP_Prof_Host_ID). 

  

 

  

In action configuration, under the Agent Profile From EIP section, set the Type to User Defined and select the EIP 

Agent Profile you previously created. Example EIP_Agent_Host_ID. The Match Categories panel will display the defined 

validation criteria, such as registry paths or process checks, ensuring that the selected EIP Agent Profile is applied for 

endpoint posture verification. 

  

 

Use Cases for MacOS 

Endpoint Information Profiles (EIP) classify endpoints based on their posture information, enabling 
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organizations to enforce security policies that ensure devices adhere to enterprise standards before 

accessing network resources. This is a core capability within a Zero Trust framework, which eliminates 

implicit trust for users or devices. 

For macOS devices, EIP can be leveraged to validate multiple attributes and determine compliance 

before granting access. Common criteria for EIP selection include: 

• Operating System: macOS major/minor version and the presence of required security updates 

(patch level). 

• Antivirus / Endpoint Protection: Status and version of the installed macOS endpoint security 

agent — for example, CrowdStrike Falcon, SentinelOne, Jamf Protect, Malwarebytes, or Mi-

crosoft Defender for Endpoint (the latter is available but less commonly used on macOS). 

• Disk Encryption: FileVault status (enabled/disabled) and encryption compliance for the system 

drive. 

• Firewall & Network Controls: Built-in macOS firewall state and whether any corporate net-

work filtering or DNS proxy agents are present and running. 

• Software Installation: Whether required corporate applications or security tools are installed 

and active. 

By leveraging these checks, administrators can enforce granular access policies. For example, a policy 

can be configured to allow access to critical SaaS applications only if the macOS device is encrypted 

with FileVault, has an approved endpoint security solution installed, and runs a supported OS 

version. This ensures that only compliant macOS endpoints connect to sensitive enterprise resources, 

strengthening security and posture validation. 

On macOS posture attributes can be verified locally by reviewing the EIP output files generated on 

the device, located under: 

/private/var/log/versa/EIP/ 
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There are two ways to check the posture information: 

• To validate a specific control such as antivirus, anti-phishing, firewall, or encryption, open the 

corresponding JSON file (e.g., check-av.json, check-anti-phishing.json, check-firewall.json, 

check-encryption.json). Each JSON file contains detailed results for that module. 

• To view all posture checks together, review DefaultProfile.log or Tenant-name.log in this 

case demo-org-23.log, which aggregates the results from every module. 
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Graphical (macOS): 

1. Right-click a JSON or log file. 

2. Choose Open With > Firefox (for better readability of JSON) or Open With > TextEdit. 

3. Review the posture results directly in the viewer. 
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Terminal (macOS): 

• view AV check (raw) 
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cat /private/var/log/versa/EIP/check-av.json 

 

• view formatted JSON (if python is available) 

python3 -m json.tool /private/var/log/versa/EIP/check-av.json | less 

 

Anti-malware 

 

Anti-malware validation within an Endpoint Identity Profile (EIP) provides a way to confirm that endpoints are 

running an approved security agent and that the protection status is healthy. This method helps ensure 

devices are protected against malicious software before being granted access to enterprise resources. 

 

For macOS devices, administrators can check the installed and running anti-malware software either through 

the EIP posture logs (/private/var/log/versa/EIP/check-av.json) or directly from the system: 

 

• To verify if a specific process (e.g., CrowdStrike, Jamf Protect, Malwarebytes) is running: 

ps aux | grep -i crowdstrike   

 

Scenario: An organization requires that all corporate laptops have an approved anti-malware agent installed 

and active (for example, CrowdStrike Falcon, Malwarebytes or Jamf Protect). In the EIP Profile, the 

administrator defines compliance rules for anti-malware. When a device connects: 

 

• If the anti-malware software is installed and running, the device is considered compliant. 

• If the software is missing or inactive, the device is flagged as non-compliant and access may be re-

stricted. 

• This ensures that only endpoints with active anti-malware protection can access sensitive corporate 

applications, reinforcing Zero Trust posture validation. 

 

Step 1: Create an EIP Object with AntiMalware 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Objects 
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Click on “+ Add” to create a new EIP Object.  

  

 

  

Enter a descriptive name for your EIP object. Example: EIP_AntiMalware_Malwarebytes.  And Select AntiMalware 

from the dropdown. 
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In the Anti-Malware section of the EIP object, configure the following options to validate that the endpoint is protected: 

• Installed: True 

• Configured: True 

• Running: True 

• Realtime: True (optional but recommended) 

• Vendor / Product: Specify the approved anti-malware solution. 

As an example, the screenshot below shows Malwarebytes configured with the values: 

o Vendor: Malwarebytes Corporation 

o Product: Malwarebytes 

 

This configuration ensures that endpoints are only considered compliant if Malwarebytes is both installed and actively 

running. If the product is missing or inactive, the device will be flagged as non-compliant and may be denied access to 

corporate resources. 
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Step 2: Create an EIP Profile Using AntiMalware 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Profiles 

  

 

  

Click on “+ Add” to start creating a new profile. 
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In the Create EIP Profile window, Click on “+ Add” to define a new rule. 

  

 

  

  

Create a  Rule for AntiMalware 

Enter a Name for your rule, Example, EIP_AntiMalware_Malwarebytes. 

 You would (Optional) Add a description for clarity. 

Click “+ Add” to attach an EIP Object. 
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In Add EIP Object dialog, choose the Category. Example AntiMalware. 

Select an existing EIP Object or create a new one. For example, an object was created to verify if MacOs AntiMalware 

Malwarebytes is installed, running and configured in the previous section. 

  

 

  

Click Next and then Enter a descriptive name for your EIP object. Example: EIP_AntiMalware_Malwarebytes. 

  

Review and Save the Profile creation 
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Note:  After creating the EIP Object and configuring the EIP Profile and Agent Profile, you must apply them to the Secure 

Access Client policy to enforce device posture validation and continue evaluation. 

Step 3: Navigate to the EIP Agent Section 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Agents 

 

 

 

Step 4: Create an EIP Agent Profile 

  

Important Note: Instead of creating a new agent manually, you can also use a predefined Versa Anti-Malware agent. 
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In the Predefined tab, search for antimalware and select the predefined category that matches your requirements. This 

option already includes baseline rules such as Installed: True, Configured: True, and others. 

  

 

 

 

Click on Add to create a new Agent profile. 

 

  

Click on “+Add” to create a new rule. Then choose general 
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In the Anti-Malware category of the Agent Profile, configure the following options: 

• Installed: True 

• Configured: True 

• Running: True 

• Realtime: True (optional but recommended) 

• Vendor: True 

• Product: True 

 

This configuration ensures that endpoints are validated for the presence and activity of anti-malware protection. Devices 

that fail any of these checks will be flagged as non-compliant and may be restricted from accessing corporate resources. 
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Click on “next” to enter a descriptive Profile Name (Example., EIP_Agent_AntiMalware). 

  

 

 



 

81 

 

 

Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

 

 

 

Step 5: Configure Secure Client Access Rule 

 

Navigate to: 

 Configure > Security Service Edge > Secure Access > Client-based Access > Rules. 

  

Click “+ Add” to create a new Secure Access Client rule or edit an existing rule. 

  

In the Match Criteria configuration, go to the Endpoint Posture section. Under the Endpoint Information Profile (EIP) 

panel, select the desired profile by navigating to the User Defined tab and clicking on Add Existing EIP Profile. Then, 

choose the EIP profile you previously created. Example EIP_AntiMalware_Malwarebytes). 
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In action configuration, under the Agent Profile From EIP section, set the Type to User Defined and select the EIP 

Agent Profile you previously created. Example EIP_AntiMalware. The Match Categories panel will display the defined 

validation criteria, such as registry paths or process checks, ensuring that the selected EIP Agent Profile is applied for 

endpoint posture verification. 

 

  

Verification 

At this time, the macOS device does not have Malwarebytes installed. When the Versa SASE Client 

attempts to connect, the authentication fails due to the EIP policy that requires an approved 

antimalware product. 
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To confirm the posture on the endpoint, you would check whether Malwarebytes is installed or running by executing 

the following command in Terminal: 

 

ps aux | grep -i Malwarebytes 

 

 

The command output shows no active Malwarebytes process, which validates that the software is not present before 

installation. 

 

In addition, reviewing the EIP posture log collected from the device confirms that only the native Apple security 

components are detected: 

• Vendor: Apple Inc. 

• Product: XProtect – version 5314 

• Product: Gatekeeper – version 13.7.8 
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This baseline confirms that the macOS endpoint currently relies only on built-in protections (XProtect and Gatekeeper) 

and does not yet meet the policy requirement for Malwarebytes 

 

 

 

After installing Malwarebytes, the Versa SASE Client is now able to authenticate successfully and establish a secure 

connection to the enterprise VPN. 
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To confirm the posture on the endpoint, you would check again whether Malwarebytes is installed and running by 

executing the following command in Terminal: 

 

ps aux | grep -i Malwarebytes 

 

 

the command output shows multiple active processes related to Malwarebytes, including the 

RTProtectionDaemon, FrontendAgent, and SettingsDaemon, which indicates that the 

antimalware agent is installed and running properly. 

Reviewing the updated EIP posture log confirms detection of Malwarebytes alongside the native 

Apple protections: 

• Vendor: Malwarebytes Corporation 

• Product: Malwarebytes – version 5.17.0.3365 

• Vendor: Apple Inc. 

• Product: XProtect – version 5314 

• Product: Gatekeeper – version 13.7.8 
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You check the Concerto logs to validate that the EIP authentication profile matches the expected 

profile. In Concerto From the log view (View > Dashboard > Secure Access > Logs > Endpoint 

Information Profile > Logs).  

 

Entry show that the endpoint matches the EIP_AntiMalware_Malwarebytes profile and rule after 

Malwarebytes is installed. The appliance, user, and host details confirm that the macOS device, 

associated with user, is evaluated against the correct profile. This confirms that the endpoint is 

recognized as compliant, the EIP profile and rule are enforced, and secure access is granted 

according to the posture policy. 
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Hostname 

Hostname validation within an Endpoint Identity Profile (EIP) provides a way to identify endpoints 

based on their configured system name. This method can help enforce organizational naming 

standards and provide an additional layer of compliance control. 

For macOS devices, administrators can configure or verify hostnames directly from the terminal: 

• To set the hostname: 

sudo scutil --set HostName "your-new-name.domain.com" 

• To check the hostname: 

scutil --get HostName 

Scenario: An organization requires all corporate laptops to follow a naming convention, such as 

hostname.department.corp.local. In the EIP Profile, the administrator defines an allowed list of 

hostnames. When a device connects: 

• If the hostname matches an entry in the allowed list, the device is considered compliant. 

• If the hostname does not match, the device is flagged as non-compliant and may be 

restricted from accessing corporate resources. 

This ensures that only systems configured with the approved naming scheme can access protected 

applications. 

 

Step 1: Create an EIP Object with hostname 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Objects 
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Click on “+ Add” to create a new EIP Object.  

  

 

  

Enter a descriptive name for your EIP object. Example: EIP_Hostname.  And Select general from the dropdown. 
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Go to Hostname and Enter the hostname to check Example: 

 mac-versalab 

  

 

 

  

 

Step 2: Create an EIP Profile Using Host ID 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Profiles 
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Click on “+ Add” to start creating a new profile. 

 

  

In the Create EIP Profile window, Click on “+ Add” to define a new rule. 

  



 

91 

 

 

Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

 

  

  

Create a General Rule for hostname 

Enter a Name for your rule, Example, EIP_Prof_Hostname_Mac. 

 You would (Optional) Add a description for clarity. 

Click “+ Add” to attach an EIP Object. 

 

In Add EIP Object dialog, choose the Category. Example general. 

Select an existing EIP Object or create a new one. For example, an object was created to verify if MacOs Hostname in 

the previous section. 
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Click Next and then Enter a descriptive name for your EIP object. Example: EIP_Hostname. 

  

Review and Save the Profile creation 

  

 

  

Note:  After creating the EIP Object and configuring the EIP Profile and Agent Profile, you must apply them to the Secure 

Access Client policy to enforce device posture validation and continue evaluation. 

Step 3: Navigate to the EIP Agent Section 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Agents 

 

  

  



 

93 

 

 

Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

 

  

Step 4: Create an EIP Agent Profile 

  

Important Note: Instead of creating a new agent manually, you can also use a predefined Versa Hostname agent. In 

the Predefined tab, search for domain and select General_category_hostname, which already includes the rule hostname: 

True.  

  

 

 

 

Click on Add to create a new Agent profile. 
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Click on “+Add” to create a new rule. Then choose general 

 

  

  

In the general section, locate click hostname by default is set to  Disable change to  true, then Click Add.  
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Click on “next” to enter a descriptive Profile Name (Example., EIP_Agent_Hostname). 
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Step 5: Configure Secure Client Access Rule 

 

Navigate to: 

 Configure > Security Service Edge > Secure Access > Client-based Access > Rules. 

  

Click “+ Add” to create a new Secure Access Client rule or edit an existing rule. 

  

In the Match Criteria configuration, go to the Endpoint Posture section. Under the Endpoint Information Profile (EIP) 

panel, select the desired profile by navigating to the User Defined tab and clicking on Add Existing EIP Profile. Then, 

choose the EIP profile you previously created. Example EIP_Prof_Hostname_Mac). 

  

 

  

In action configuration, under the Agent Profile From EIP section, set the Type to User Defined and select the EIP 

Agent Profile you previously created. Example EIP_Agent_Host_ID. The Match Categories panel will display the defined 

validation criteria, such as registry paths or process checks, ensuring that the selected EIP Agent Profile is applied for 

endpoint posture verification. 
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Disk- Encryption 

 

Disk encryption validation within an EIP verifies that endpoints use full-disk encryption before access is 

granted, helping protect data at rest on lost or stolen devices. 

For macOS devices, administrators can check encryption status either through the EIP posture logs 

(/private/var/log/versa/EIP/check-encryption.json) or directly from the system: 

•  To verify FileVault status from the command line: 

fdesetup status 

• FileVault is On > the system drive is encrypted. 

• FileVault is Off > the system drive is not encrypted. 

• Encryption in progress > the drive is currently encrypting. 

•  

Note (macOS): Disk encryption is available natively via FileVault (built in by default). You can enable it in 

System Settings → Privacy & Security → FileVault or via CLI (sudo fdesetup enable). If your organization 

uses a third-party disk-encryption tool, confirm that the EIP posture checks recognize that solution before 

enforcing compliance. 

 

Scenario: An organization requires all corporate Macs to have disk encryption enabled (As an Example 

FileVault). In the EIP Profile, the administrator defines compliance rules for disk encryption. When a device 

connects: 

• If disk encryption is enabled and running, the device is considered compliant. 

• If disk encryption is disabled, enabled but is not detected, the device is non-compliant and 
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access may be restricted. 

• This ensures only endpoints with full-disk encryption can access sensitive corporate applica-

tions, reinforcing Zero Trust posture validation. 

 

Step 1: Create an EIP Object with Disk Encryption 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Objects 

  

 

  

Click on “+ Add” to create a new EIP Object.  
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Enter a descriptive name for your EIP object. Example: EIP_DiskEncryption.  And Select DiskEncryption from the 

dropdown. 

 

  

 

In the Disk-Encryption section of the EIP object, configure the following options to validate that the endpoint is 

protected: 

• Installed: True 

• Configured: True 

• Running: True 

• Vendor / Product: Specify the approved Disk Encryption solution. 



 

100 

 

 

Step-By-Step Guide for Endpoint Identity Profile (EIP) Configuration 

As an example, the screenshot below shows FileVault by Apple configured with the values: 

o Vendor: Apple 

o Product: FileVault 

 

This configuration ensures that endpoints are only considered compliant if FileVault disk encryption is installed, 

configured, and actively running. If FileVault is disabled or not active, the device is flagged as non-compliant and may 

be denied access to corporate resources.  

  

 

  

  

 

Step 2: Create an EIP Profile Using Disk Encryption 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Profiles 
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Click on “+ Add” to start creating a new profile. 

 

  

In the Create EIP Profile window, Click on “+ Add” to define a new rule. 
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Create a  Rule for Disk Encryption 

Enter a Name for your rule, Example, EIP_DiskEncryption_FileVault. 

 You would (Optional) Add a description for clarity. 

Click “+ Add” to attach an EIP Object. 

 

In Add EIP Object dialog, choose the Category. Example DiskEncryption. 

Select an existing EIP Object or create a new one. For example, an object was created to verify if MacOs DiskEncryption 

is installed, running and configured in the previous section. 
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Click Next and then Enter a descriptive name for your EIP object. Example: EIP_DiskEncry_FileVault. 

  

 

Review and Save the Profile creation 

  

 

 

Note: After creating the EIP Object and configuring the EIP Profile and Agent Profile, you must apply them to the Secure 

Access Client policy to enforce device posture validation and continue evaluation. 

  

Step 3: Navigate to the EIP Agent Section 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Agents 
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Step 4: Create an EIP Agent Profile 

 

Important Note: Instead of creating a new agent manually, you can also use a predefined Versa Disk-Encryption agent. 

In the Predefined tab, search for diskencryption and select the predefined category that matches your requirements. 

This option already includes baseline rules such as Installed: True, Configured: True, and others. 

  

  

 

  

 

Click on Add to create a new Agent profile. 
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Click on “+Add” to create a new rule. Then choose general 

 

  

In the Disk Encryption category of the Agent Profile, configure the following options: 

• Installed: True 

• Configured: True 

• Running: True 

• Vendor True 

• Product True 

 

This configuration ensures that endpoints are validated for the presence and activity of disk encryption. Devices that fail 
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any of these checks are flagged as non-compliant and may be restricted from accessing corporate resources. 

 

 

  

Click on “next” to enter a descriptive Profile Name (Example., EIP_Agent_DiskEncryp_FileVault). 
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Step 5: Configure Secure Client Access Rule 

 

Navigate to: 

 Configure > Security Service Edge > Secure Access > Client-based Access > Rules. 

  

Click “+ Add” to create a new Secure Access Client rule or edit an existing rule. 

  

In the Match Criteria configuration, go to the Endpoint Posture section. Under the Endpoint Information Profile (EIP) 

panel, select the desired profile by navigating to the User Defined tab and clicking on Add Existing EIP Profile. Then, 

choose the EIP profile you previously created. Example EIP_DiskEncry_FileVault). 
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In action configuration, under the Agent Profile From EIP section, set the Type to User Defined and select the EIP 

Agent Profile you previously created. Example EIP_Agent_DiskEncryp_FileVault. The Match Categories panel will display 

the defined validation criteria, such as registry paths or process checks, ensuring that the selected EIP Agent Profile is 

applied for endpoint posture verification. 

 

  

Verification 

At this time, the macOS device has FileVault disk encryption installed and configured; however, it is 

not running. When the Versa SASE Client attempts to connect, the authentication fails due to the EIP 

policy that requires active disk encryption. 
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To confirm the posture on the endpoint, you would check whether FileVault is enabled and running by executing the 

following command in Terminal: 

 

fdesetup status 

 

 

 

The command output shows that FileVault is not active, which validates that disk encryption is not running on the device. 

 

In addition, reviewing the EIP posture log collected from the device confirms that FileVault disk encryption is detected: 

• Vendor: Apple Inc. 

• Product: FileVault – version 13.7 

• Installed: True 

• Configured: True 

• Running: False 
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This indicates that FileVault is present on the macOS endpoint but not actively running, meaning the device does not 

yet meet the EIP policy requirement for disk encryption. 

 

 

 

After enabling FileVault and disk encryption is running, the Versa SASE Client is able to authenticate successfully and 

establish a secure connection to the enterprise VPN. 
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To confirm the posture on the endpoint, you would check again whether FileVault disk encryption is enabled and 

running by executing the following command in Terminal: 

fdesetup status 

 

The command output shows “FileVault is On”, which validates that disk encryption is enabled and 

actively protecting the macOS device. 

You are able to check the disk encryption status directly in the EIP posture logs located under 

/private/var/log/versa/EIP/demo-org-23.log. In the log, the Disk Encryption section lists FileVault 

with the attributes is-installed: true, is-configured: true, and is-running: true. This confirms that 

FileVault disk encryption is enabled and actively protecting the macOS device, allowing the endpoint 

to meet the EIP policy requirement for disk encryption compliance. 

 

You check the Concerto logs to validate that the EIP authentication profile matches the expected 

profile. In Concerto From the log view (View > Dashboard > Secure Access > Logs > Endpoint 

Information Profile > Logs).  
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Entry show that the endpoint matches the EIP_DiskEncry_FileVault profile and rule after 

DiskEncryption is running. The appliance, user, and host details confirm that the macOS device, 

associated with user, is evaluated against the correct profile. This confirms that the endpoint is 

recognized as compliant, the EIP profile and rule are enforced, and secure access is granted 

according to the posture policy. 

Combined Posture Validation: Disk Encryption + Firewall (CrowdStrike) 

 

This case validates that macOS endpoints not only have full-disk encryption enabled but also run an approved 

firewall solution. By combining these checks, organizations can enforce stronger posture requirements that 

protect both data at rest and network-level security before granting access to enterprise resources. 

For macOS devices, administrators can verify both controls using the EIP posture logs 

(/private/var/log/versa/EIP/demo-org-23.log) or directly from the system: 

• To verify disk encryption status (FileVault): 

o fdesetup status 

▪ FileVault is On → the system drive is encrypted. 

▪ FileVault is Off → the system drive is not encrypted. 

▪ Encryption in progress → the drive is currently encrypting. 

• To verify the firewall (CrowdStrike Falcon): 

o ps aux | grep -i crowdstrike 

 

This confirms if the CrowdStrike Falcon agent, which provides firewall and network protection on macOS, is 

installed and actively running. 

Scenario: An organization requires all corporate Macs to have FileVault enabled and the CrowdStrike 

Falcon firewall service active. In the EIP Profile, the administrator defines compliance rules for both Disk 
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Encryption and Firewall categories. When a device connects: 

• If FileVault is enabled and running and the CrowdStrike Falcon firewall is installed and active, the 

device is considered compliant. 

• If either control is missing, disabled, or not detected, the device is non-compliant and access may be 

restricted. 

• This ensures that only endpoints providing both strong encryption and active network protection can 

access sensitive corporate applications, reinforcing Zero Trust posture validation. 

 

Step 1: Create an EIP Object Disk Encryption 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Objects 

  

 

  

Click on “+ Add” to create a new EIP Object.  
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Enter a descriptive name for your EIP object. Example: EIP_DiskEncryption.  And Select DiskEncryption from the 

dropdown. 

 

  

 

In the Disk-Encryption section of the EIP object, configure the following options to validate that the endpoint is 

protected: 

• Installed: True 

• Configured: True 

• Running: True 

• Vendor / Product: Specify the approved Disk Encryption solution. 
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As an example, the screenshot below shows FileVault by Apple configured with the values: 

o Vendor: Apple 

o Product: FileVault 

 

This configuration ensures that endpoints are only considered compliant if FileVault disk encryption is installed, 

configured, and actively running. If FileVault is disabled or not active, the device is flagged as non-compliant and may 

be denied access to corporate resources.  

  

 

 

Step 2: Validate an EIP Object for Firewall (CrowdStrike) 

 

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Objects 
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Click on “+ Add” to create a new EIP Object.  

  

 

 In the Firewall section of the EIP object, configure the following options to validate that the endpoint is protected: 

• Installed: True 

• Configured: True 

• Running: True 

• Vendor / Product: Specify the approved Crowdstrike solution. 

As an example, the screenshot below shows Falcon Crowdstrike by CrowdStrike Falcon configured with the values: 

o Vendor: Crowdstrike 

o Product: crowdstrike 
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This configuration ensures that endpoints are only considered compliant if CrowdStrike Falcon is installed, 

configured, and actively running. If Crowdstrike is disabled or not active, the device is flagged as non-compliant and 

may be denied access to corporate resources.  

  

 

 

 

Step 3: Create an EIP Profile with Combined Posture Validation (Disk Encryption + Endpoint Security) 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Profiles 
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Click on “+ Add” to start creating a new profile. 

 

  

In the Create EIP Profile window, Click on “+ Add” to define a new rule. 
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Create a  Rule for Disk Encryption 

Enter a Name for your rule, Example, EIP_DiskEncryption_FileVault. 

 You would (Optional) Add a description for clarity. 

Click “+ Add” to attach an EIP Object. 

 

 

In Add EIP Object dialog, choose the Category. Example DiskEncryption. 

Select an existing EIP Object or create a new one. For example, an object was created to verify if MacOs DiskEncryption 

is installed, running and configured in the previous section. 
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Now add other object  In Add EIP Object dialog, choose the Category. Example Firewall. 

Select a EIP Object for crowdstrike (“EIP_Firewall_Crowdstrike”). For example, this object verifies if Crowdstrike Falcon is 

installed, running, etc. Those steps explained in the previous section. 

 

 

 Now Save Rule 
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Click Next and then Enter a descriptive name for your EIP object. Example: EIP_Mac_Posture_Validation. 

 

Review and Save the Profile creation 

 

  

 

Note: After creating the EIP Object and configuring the EIP Profile and Agent Profile, you must apply them to the Secure 

Access Client policy to enforce device posture validation and continue evaluation. 
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Step 4: Navigate to the EIP Agent Section 

  

Navigate to Configure > Security Service Edge > Profile and Connectors > Endpoint Information Profile (EIP) > EIP 

Profiles then go EIP Agents 

 

 

  

Step 5: Create an EIP Agent Profile 

 

Important Note: Instead of creating a new agent manually, you can also use a predefined Versa Versa_Recommend 

agent. In the Predefined tab, search for Versa. This option already includes baseline rules such as Installed: True, 

Configured: True, etc. for multiple categories and others. 
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Click on Add to create a new Agent profile. 

 

  

Click on “+Add” to create a new rule. Then choose general 

 

  

In the Disk Encryption category of the Agent Profile, configure the following options: 

• Installed: True 

• Configured: True 

• Running: True 

• Vendor True 

• Product True 
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This configuration ensures that endpoints are validated for the presence and activity of disk encryption. Devices that fail 

any of these checks are flagged as non-compliant and may be restricted from accessing corporate resources. 

 

 

 

Add another category, Firewall in the Agent Profile and configure the following options: 

• Installed: True 

• Configured: True 

• Running: True 

• Vendor: True 

• Product: True 

This configuration ensures that endpoints are validated for the presence and activity of the endpoint security agent. 

When combined with the Disk Encryption category, the EIP posture validation enforces that both FileVault disk 

encryption and the firewall solution ( CrowdStrike Falcon) are active. 

 

  

Click on “next” to enter a descriptive Profile Name (Example., EIP_Ag_Posture_Mac_Validation). 
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Step 6: Configure Secure Client Access Rule 

 

Navigate to: 

 Configure > Security Service Edge > Secure Access > Client-based Access > Rules. 

  

Click “+ Add” to create a new Secure Access Client rule or edit an existing rule. 

  

In the Match Criteria configuration, go to the Endpoint Posture section. Under the Endpoint Information Profile (EIP) 
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panel, select the desired profile by navigating to the User Defined tab and clicking on Add Existing EIP Profile. Then, 

choose the EIP profile you previously created. Example EIP_Mac_Posture_Validation). 

  

 

  

In action configuration, under the Agent Profile From EIP section, set the Type to User Defined and select the EIP 

Agent Profile you previously created. Example EIP_Ag_Posture_Mac_Validation. The Match Categories panel will 

display the defined validation criteria, such as registry paths or process checks, ensuring that the selected EIP Agent Profile 

is applied for endpoint posture verification. 

 

  

Verification 

At this time, the macOS device has FileVault disk encryption installed, configured; and running. When 
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the Versa SASE Client attempts to connect, the authentication fails due to the EIP policy that requires 

Crowdstrike Falcon Firewall is running. 

 

To confirm the posture on the endpoint, you would check whether FileVault is enabled and running by executing the 

following command in Terminal: 

 

fdesetup status 

 

 

 

The command output shows that FileVault is active, which validates that disk encryption is running on the device. 

However, to verify Firewall (CrowdStrike Falcon: 

• ps aux | grep -i crowdstrike 

 The command output shows that CrowdStrike Falcon agent is installed, however firewall feature is not running on 

the device. 
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In addition, reviewing the EIP posture log collected from the device confirms that FileVault disk encryption is detected 

with the following attributes: 

• Vendor: Apple Inc. 

• Installed: True 

• Configured: True 

• Running: True 

And that CrowdStrike Falcon as well is detected with the following attributes: 

• Vendor: CrowdStrike. 

• Installed: True 

• Configured: True 

• Running: False 

 

Logs show that CrowdStrike Falcon is installed. However, it is not running this means that while disk encryption is active 

and compliant, the firewall requirement is not met. As a result, the macOS device does not fully satisfy the EIP policy, 

since both controls — disk encryption and firewall — must be enabled to achieve compliance. 
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After enabling Firewall Crowdstrike Falcon and it is running, the Versa SASE Client is able to authenticate successfully 

and establish a secure connection to the enterprise VPN. 

 

 

 

To confirm the posture on the endpoint, you would check again whether FileVault disk encryption is enabled and 

running by executing the following command in Terminal: 

fdesetup status 

 

The command output shows “FileVault is On”, which validates that disk encryption is enabled and 

actively protecting the macOS device.  

And to confirm if CrowdStrike Falcon is installed ps aux | grep -i crowdstrike 

 

 

The command output shows that CrowdStrike Falcon agent is installed and actively protecting the macOS device. 
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You are able to check the disk encryption and firewall status directly in the EIP posture logs located 

under /private/var/log/versa/EIP/demo-org-23.log. 

 

You check the Concerto logs to validate that the EIP authentication profile matches the expected 

profile. In Concerto From the log view (View > Dashboard > Secure Access > Logs > Endpoint 

Information Profile > Logs).  

 

Entry show that the endpoint matches the EIP_Mac_Posture_Validation profile and rule after 

DiskEncryption and Firewall are running. The appliance, user, and host details confirm that the 

macOS device, associated with user, is evaluated against the correct profile. This confirms that the 

endpoint is recognized as compliant, the EIP profile and rule are enforced, and secure access is 

granted according to the posture policy. 
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About Versa 

Versa, the global leader in SASE, enables organizations to create self-protecting networks that radically 
simplify and automate their network and security infrastructure. Powered by AI, the VersaONE Universal 
SASE Platform delivers converged SSE, SD-WAN, and SD-LAN solutions that protect data and defend 
against cyberthreats while delivering a superior digital experience. Thousands of customers globally, with 
hundreds of thousands of sites and millions of users, trust Versa with their mission critical networks and 
security. Versa is privately held and funded by investors such as Sequoia Capital, Mayfield, and BlackRock. 
For more information, visit https://www.versa-networks.com and follow Versa on LinkedIn and X (Twit-
ter) @versanetworks. 
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